Search This Blog

Loading...

Wednesday, August 11, 2010

No Blooms !



Cardinal Climbers gave me only FOUR flowers this year so far...c'mon !!!
Last year they didn't bloom 'til September which is kinda late for the humming birds.
(the only reason I grow 'em).
Maybe will try something different next year. Grrrrrr !!




Obedient Plant or Physostegia 'Vivid' 2nd year. Nada !
Just don't get it.




Had this Mophead for 5-6 years.
It bloomed the first year very well, while in same location less the second year. Then stopped all together.
Since then even with moving it .....it just won't bloom.




Had to show at less one flower....
Gotta get real close to see this little Blackberry lily flower.
But I do like the foliage so it's a keeper...started from seed maybe 5 years ago.


5 comments:

  1. Hi Patsi. Don't these plants just aggravate a person sometimes LOL! I feel that way about the stupid wisteria vine I have waited on forever to bloom. You hate them taking up the space if they are not going to preform but that hope just keeps you waiting. LOL! Not nice.

    ReplyDelete
  2. My obedient plant is very slow to bloom this year, in fact only one flower so far. I'm not sure what's going on. I have a wisteria, too, that has never bloomed. Oh well.

    ReplyDelete
  3. So sorry, Patsi :( My obedient plant is just beginning to bloom. I love your Blackberry Lily ... years ago I purchased seeds from Mt. Vernon ... they were doing well then, one year, disappeared. Don't despair, it's only midsummer!

    ReplyDelete
  4. It is frustrating when plants just don't perform as they should. Damn flowers! ha ha ha! Hang in there.

    ReplyDelete
  5. Well I feel your pain with the Obedient plant...mine are so small and not close to getting blooms. I thought they were blooming (and very tall) this time last year. Wonder what the problem is?

    ReplyDelete

Thanks for your visit and comment.

Glad to answer questions when I visit you...

Making life easier is a good thing.